[+]
SORT Support
[+]
SORT Suggestions
/ Downloads / Patches / Patch Detail
This page lists publically-released patches for Symantec Enterprise Products.
For information on private patches, contact Symantec Technical Support.
For NetBackup Enterprise Server and NetBackup Server patches, see the NetBackup Downloads.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vcs-sles9_x86_64-5.0MP3RP2HF1
Obsolete
The latest patch(es) : sfha-sles9_x86_64-5.0MP4 
Sign in if you want to rate this patch.

 Basic information
Patch type: Hot Fix
Release date: 2009-02-16
Technote: 319977
Documentation: None
Popularity: 237 viewed    11 downloaded
Download size: 1.28 MB
Checksum: 3631461581

 Applies to one or more of the following products:
Cluster Server 5.0MP3 On SLES9 x86-64
Storage Foundation Cluster File System 5.0MP3 On SLES9 x86-64
Storage Foundation Cluster File System for Oracle RAC 5.0MP3 On SLES9 x86-64
Storage Foundation for DB2 5.0MP3 On SLES9 x86-64
Storage Foundation for Oracle 5.0MP3 On SLES9 x86-64
Storage Foundation for Oracle RAC 5.0MP3 On SLES9 x86-64
Storage Foundation HA 5.0MP3 On SLES9 x86-64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
sfha-sles9_x86_64-5.0MP4 2010-04-11
vcs-sles9_x86_64-VRTSgab-5.0MP3RP2HF2 (obsolete) 2009-09-17

 Fixes the following incidents:
1509742

 Patch ID:
VRTSgab-5.0.30.21-MP3RP2HF1_SLES9

 Readme file  [Save As...]
Date: 2009-02-16
OS: Linux x86_64
OS Version: SUSE 9 with SP3 or SP4
Packages: VRTSgab
Etrack Incidents: 1509742

VERITAS CLUSTER SERVER 5.0 MP3RP2 - GAB HOT FIX 1 FOR LINUX
===========================================================

PATCH NAME:			5.0MP3RP2HF1
PATCH DATE:			February 2009
REQUIRED VCS RELEASE:		5.0MP3RP2
RELEVANT LINUX RELEASES:	RHEL4, RHEL5, SLES9, SLES10, OEL4.4, OEL5.1
RELEVANT ARCHITECTURES:		x86_64

POINT PATCH SUMMARY OF CONTENTS:
--------------------------------
This cumulative patch contains the following:
	README (this file)
	package for RHEL4, OEL4.4 (VRTSgab-5.0.30.21-MP3RP2HF1_RHEL4.x86_64.rpm)
	package for RHEL5, OEL5.1 (VRTSgab-5.0.30.21-MP3RP2HF1_RHEL5.x86_64.rpm)
	package for SLES9 (VRTSgab-5.0.30.21-MP3RP2HF1_SLES9.x86_64.rpm)
	package for SLES10 (VRTSgab-5.0.30.21-MP3RP2HF1_SLES10.x86_64.rpm)


FILES AFFECTED BY THIS PATCH:
-----------------------------

VRTSgab - Veritas Group Membership and Atomic Broadcast
The entire package is included with the patch.

FIXED INCIDENT:
--------------
Following is a brief description of the incident fixed in this patch.

Clients of the GAB service may not get cluster membership.[e1509742]
Symantec recommends that GAB must be configured to provide membership only
after a minimum quorum number of nodes join the cluster.
If a client of GAB comes up before GAB Port a formed membership on that
node, then this client may not get cluster membership until it starts up
on at least the (configured) quorum number of nodes, not even if Port a 
or any other GAB Ports receive cluster membership.

CKSUM:
------
For RHEL4 & OEL4.4 specific package
# cksum VRTSgab-5.0.30.21-MP3RP2HF1_RHEL4.x86_64.rpm
907217332       461687  VRTSgab-5.0.30.21-MP3RP2HF1_RHEL4.x86_64.rpm

For RHEL5 & OEL5.1 specific package
# cksum VRTSgab-5.0.30.21-MP3RP2HF1_RHEL5.x86_64.rpm
1406437893      823553  VRTSgab-5.0.30.21-MP3RP2HF1_RHEL5.x86_64.rpm

For SLES9 specific package
# cksum VRTSgab-5.0.30.21-MP3RP2HF1_SLES9.x86_64.rpm
1621675363      1346031 VRTSgab-5.0.30.21-MP3RP2HF1_SLES9.x86_64.rpm

For SLES10 specific package
# cksum VRTSgab-5.0.30.21-MP3RP2HF1_SLES10.x86_64.rpm
786789503       1675018 VRTSgab-5.0.30.21-MP3RP2HF1_SLES10.x86_64.rpm

INSTALLING THE PATCH:
---------------------

This patch must be installed after installing
Veritas Cluster Server 5.0MP3RP2.

Perform the following steps on every system in the cluster.

1. Log on as superuser on the system on which the point patch is to be
   installed.

2. Presistently freeze that node in VCS:
	# /opt/VRTSvcs/bin/haconf -makerw
	# /opt/VRTSvcs/bin/hasys -freeze <nodename> -persistent
	# /opt/VRTSvcs/bin/haconf -dump -makero

3. Stop all clients of GAB. For example:
   a) For VCS, run the following command:
        # /etc/init.d/vcs stop

   b) For VxFEN:
        # /etc/init.d/vxfen stop

   Take care to also shutdown any components dependant on these clients.
   Take care to observe correct order.

4. Stop GAB:
        # /etc/init.d/gab stop

5. Upgrade VRTSgab package as per the Linux distribution running 
   on the system:

	For RHEL4 or OEL4.4, use the following command:
	# rpm -Uvh VRTSgab-5.0.30.21-MP3RP2HF1_RHEL4.x86_64.rpm

	For RHEL5 or OEL5.1, use the following command:
	# rpm -Uvh VRTSgab-5.0.30.21-MP3RP2HF1_RHEL5.x86_64.rpm

	For SLES9, use the following command:
	# rpm -Uvh VRTSgab-5.0.30.21-MP3RP2HF1_SLES9.x86_64.rpm

	For SLES10, use the following command:
	# rpm -Uvh VRTSgab-5.0.30.21-MP3RP2HF1_SLES10.x86_64.rpm

6. Start GAB by using the following command:
        # /etc/init.d/gab start

7. Start all the stopped GAB clients. For example:
   a) For VxFEN, run the following command:
       # /etc/init.d/vxfen start

   b) For VCS, run the following command:
        # /etc/init.d/vcs start

   Take care to also bring up any components that are dependent on the clients
   that were stopped in step 3. Take care to observe correct order.

8. Persistently unfreeze the system in VCS:
	# /opt/VRTSvcs/bin/haconf -makerw
	# /opt/VRTSvcs/bin/hasys -unfreeze <nodename> -persistent
	# /opt/VRTSvcs/bin/haconf -dump -makero



Feedback
Click here to rate this page
Read and accept Terms of Service